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Introduction
Thank you for purchasing a Korg MIDI controller.
To help you get the most out of your new instrument, please read this manual carefully.

What is the KORG KONTROL Editor?
The KORG KONTROL Editor lets you edit the parameters in your Korg MIDI controller, and save the
settings on your computer.

Caution
Do not disconnect your Korg MIDI controller while the KORG KONTROL Editor is running.

Do not use your Korg MIDI controller or the KORG KONTROL Editor while any data is being trans-
mitted.

Operating requirements
Mac OS X

Computer Apple Macintosh computer with Intel or Power PC processor that is equipped
with a USB port and meets the requirements for Mac OS X

Operating system Mac OS X 10.4 or later

Windows
Computer Computer equipped with a USB port (a USB chipset made by Intel is recom-

mended) that meets the requirements for Windows XP/Vista /7
Operating system Windows XP SP3(32bit) or later, Windows Vista SP2(32bit, 64bit) or Windows

7(32bit, 64bit)

Keyboard operation is not guaranteed with all computers that satisfy these system requirements.
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Installation

Installation for Windows users
Proceed as follows to install the software in Windows.

1 Double-click “Setup_E.exe” to start the installation process.

2 The KORG KONTROL Editor Installer screen will appear. Follow the on-screen directions to install the

software.

Installation for Mac OS X users
Proceed as follows to install the software in Mac OS X.

1 Double-click “KORG KONTROL Editor.pkg” to start the installation process.

2 Once the installer begins, follow the on-screen directions to complete the installation.
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Quick start

Starting the KORG KONTROL Editor
In order to use the KORG KONTROL Editor, you must download the Korg USB-MIDI driver from the
Korg website and install it as described in the accompanying documentation. (http://www.korg.com)

1 Use a USB cable to connect your Korg MIDI controller to your computer.

2 In the “KORG”-“KORG KONTROL Editor” folder, select “KORG KONTROL Editor” to begin.

Mac OS X The “KORG” folder is located in the “Applications” folder.

Windows The “KORG” folder is located in the taskbar “Start”-“All Programs”

3 The main screen for the connected controller will appear, and then scene data will automatically be

read from the Korg MIDI controller.

If more than one Korg MIDI controller is connected, a Korg MIDI controller selection screen will
appear. Select the device whose settings you want to edit.

Editing scene data
Here’s how to edit scene data in the main screen.

1) SCENE buttons will be displayed if the device has more than one scene. Click the scene that you want to edit.
2) In the screen, click the control that you want to edit.
3) The parameters of the selected control are shown in the parameter edit area in the lower right pane.

Here you can edit the parameters.
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What are scene data and scene sets?
Parameters are assigned to the controls (sliders, knobs, X-Y pad, etc.) of a Korg MIDI controller. These
parameter assignments are collectively called “scene data.”
Some Korg MIDI controllers have more than one scene; a collection of these scenes is called a “scene set.”

Writing scene data into your Korg MIDI controller
In order for the parameters that you’ve edited in the KORG KONTROL Editor to be reflected in your Korg
MIDI controller, you’ll need to write the edited scene data into the Korg MIDI controller. Here’s how:
From the “Send” menu, choose “Write Scene Data.” A confirmation dialog box will appear, then click the
OK button.

Do not use your Korg MIDI controller or KORG KONTROL Editor while any data is being transmit-
ted.
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KORG KONTROL Editor screens and functions
This section provides a brief explanation of the KORG KONTROL Editor’s screens and their functions.

Device select screen
Here you can select the device (Korg MIDI controller) that you want to edit.

When you select a device, information about that device will appear in the right side of the screen.
If this is the device whose parameter settings you want to edit, click the OK button.

Show only connected devices
The KORG KONTROL Editor allows you to edit the parameters of a device that is not connected. To do so,
un-check the “Show only connected devices” check box.
Select this check box if you want to see only the that are connected.

If the preference setting “Specify MIDI ports manually” is on, you won't be able to set the “Show only
connected devices” option.
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Main screen
The main screen is where you can edit your device’s scene data.

SCENE button GLOBAL button

Controls

CONTROL tab

BROWSE tab Parameter display switch

Parameter edit area

Device

Items in the screen and their function

Device
This area shows an image of the device that you selected in the device select screen.

SCENE button
Click the SCENE button of the scene that you want to edit.

This button may not be displayed, depending on the selected device.

GLOBAL button
Click the GLOBAL button to access the global data edit screen.
On the global data edit screen, you can set, transfer, save or load data.

This button may not be displayed, depending on the selected device.

Parameter display switch
This lets you switch the parameters that are shown over each control in the device image.

Parameter edit area
This area enables you to view and edit the parameters of the selected control.

Controls
This area shows the parameters that you selected using the parameter display switch.
If you've selected a parameter that the control does not have, this will indicate “--”.
When you click this, the parameters of the control will appear in the parameter display area.
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Switching the BROWSE / CONTROL tabs

BROWSE tab
This shows the folder hierarchy of your computer’s hard disk.
From the folder and file tree, you can select a scene set file and load it.

CONTROL tab
This lists the controls.
When you click in the control list, the parameters of that control will appear in the parameter edit area.

Basic operation
Here’s the basic procedure for editing in the main screen.

1 If your device has more than one scene, SCENE buttons are displayed. Select the scene that you want

to edit.

2 Click a control in the device image or in the control list of the CONTROL tab.

3 The parameters of the selected control are shown in the parameter edit area. Edit the parameters here.

For details on each parameter, refer to the owner's manual of your Korg MIDI controller.

Other operations

Cut, Copy, Paste, Clear
You can edit the setting for the SCENE buttons and the controls in the CONTROL tab, by performing
“Cut,” “Copy,” “Paste,” and “Clear” operations from the “Edit” menu.

Drag and drop
You can exchange the setting for the SCENE buttons and the controls in the CONTROL tab, you can
exchange the settings by dragging and dropping. To copy the settings, drag and drop while holding down
the Ctrl key (Mac: Option key).

Undoing the most recent operation
By selecting the “Undo” command from the “Edit” menu you can undo the previous operation.

Redoing an undone operation
By selecting the “Redo” command from the “Edit” menu you can return to the state prior to executing the
“Undo” command.
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Preference settings
Choose “Preferences ...” from the “Edit” menu to access the Preferences dialog box.

MIDI ports

Specify MIDI ports manually
Turn this on if you want to specify the MIDI ports manually instead of using automatic device detection.
If this setting is on, use the MIDI IN and MIDI OUT fields to specify the ports to which your Korg MIDI
controller is connected.

MIDI IN
Specify the MIDI IN port to which your Korg MIDI controller is connected.

MIDI OUT
Specify the MIDI OUT port to which your Korg MIDI controller is connected.

Other

Load data automatically
If this setting is off, scene data will not be automatically loaded from your Korg MIDI controller when the
main screen for the device is shown.

Warn when writing data
If this setting is off, a warning dialog box will not appear when writing data to your Korg MIDI controller.
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File management
The following data can be transferred between the KORG KONTROL Editor and your Korg MIDI control-
ler.

Device Type Content Extension

nanoKEY Scene data All parameters that can be set on the nanoKEY,
such as velocity curve and MIDI channel. nanokey_data

Scene data All parameters in one nanoPAD scene, such as
trigger pads and X-Y pad. nanopad_data

nanoPAD Scene set Parameters for four scenes.
(not including global parameters) nanopad_set

Global data The nanoPAD’s global parameters, such as
the global MIDI channel and velocity curve. nanopad_glob

nanoKONTROL
Scene data All parameters in one nanoKONTROL

scene, such as sliders and buttons. nktrl_data

Scene set Parameters for four scenes nktrl_set

microKEY Scene data All parameters that can be set on the microKEY,
such as velocity curve and MIDI channel. microkey_data
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Menu

File

Select device
Opens the device select screen.

New
Creates a new scene set for the device that is currentry selected.

Open
Loads a scene set file. If you select a file for a device other than the one selected in the main screen, the
main screen for the device of the selected file will appear.

For devices that do not feature multiple scenes, use this command to load scene data.

Save
Saves the currently-edited scene set by overwriting the existing scene set file.

For devices that do not feature multiple scenes, use this command to save scene data to an existing
file.

Save As
Saves the currently-edited scene set as a new file with the name you specify.

For devices that do not feature multiple scenes, use this command to save scene data as a new file.

Load Scene Data
Loads a scene data file into the currently-edited scene.

This command is unavailable for devices that do not feature multiple scenes.

Save Scene Data
Saves the currently-edited scene as a scene data file.

This command is unavailable for devices that do not feature multiple scenes.

Edit

Undo
Returns to the state prior to the previous operation.

Redo
Returns to the state prior to executing the Undo command.

Cut
Cuts the selected scene data or control parameter.

Copy
Copies the selected scene data or control parameter.

Paste
Pastes the cut or copied content to the selected scene data or control parameter.
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Clear
Clears the selected scene data or control parameter.

Preferences
Displays the Preferences dialog box.

Send

Load Scene Set
Loads the scene set from your Korg MIDI controller.

Write Scene Set
Writes the currently-edited scene set to your Korg MIDI controller.

Load Scene Data
Loads the scene data of the scene currently selected in the KORG KONTROL Editor from your Korg MIDI
controller.

Write Scene Data
Writes the scene data of the scene currently selected in the KORG KONTROL Editor to your Korg MIDI
controller.

Help

About
Displays the software version of the KORG KONTROL Editor.
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Troubleshooting

Software won’t start up
• Make sure that your computer meets the operating requirements.

• Check whether other applications might be running.
If other applications are running, KORG KONTROL Editor might be unable to start up, or might be
unable to transfer data.
If you’re unable to start up, close all other applications and try again.

Can’t transfer data
• Make sure that the microKEY has been detected by the connected computer.

If you are using Windows XP, go to the Control Panel, open “Sounds, Speech, and Audio Devices” ➞
“Sounds and Audio Devices,” and check the “Hardware” tab page.
If you are using Windows Vista/7, go to the Control Panel, open “Hardware and Sounds” ➞ “De-
vice Manager,” and check the “Sound, Video, and Game Controllers” tab.
If you are using Mac OS X, open “Applications” ➞ “Utilities,” then start “Audio MIDI Setup.”
For Mac OS X 10.5 or earlier, check the “MIDI Devices” tab.
For Mac OS X 10.6 or later, open and check the “MIDI Studio” window by selecting “Show MIDI
Window” from the “Window” menu.

• Make sure that the latest Korg USB-MIDI driver is installed.
You can download the latest Korg USB-MIDI driver from the Korg website.
http://www.korg.co.jp/English/Distributors/ or http://www.korg.com

• If you’re specifying the MIDI ports manually, make sure that the MIDI port settings are correct.


